VPN zwischen LANCOM R883VAW und LANCOM Client

Forum zum Thema allgemeinen Fragen zu VPN

Moderator: Lancom-Systems Moderatoren

Antworten
m71service
Beiträge: 3
Registriert: 29 Sep 2022, 15:02

VPN zwischen LANCOM R883VAW und LANCOM Client

Beitrag von m71service »

Hallo liebe LANCOM Experten,

mit zunehmendem Frust versuche eine VPN Verbindung zu dem LANCOM R883VAW mit Hilfe des LANCOM Clients aufzubauen (also Home-Office-Szenario) aber komme nicht weiter, vielleicht könnt ihr mir weiterhelfen.
Der LANCOM hängt direkt am Telekom DSL und hat eine statische IP Adresse. Beim Einrichten verwende ich diesen 1-Click VPN Wizard vom LANConfig, da purzelt dann mein INI-File raus, das ich in den Client als Profil importiere.

Die Logdatei für den Verbindungsversuch sieht so aus:

Code: Alles auswählen

29.09.2022 15:10:22 - INFO - MONITOR: Communication Medium changed  -  Automatic => Wi-Fi
29.09.2022 15:10:22 - System: DNSHandling=0
29.09.2022 15:10:22 - IPSec: Start building connection
29.09.2022 15:10:22 - IpsDial: Created the following list of provider links:
29.09.2022 15:10:22 - IpsDial: connection time interface choice,LocIpa=192.168.2.46,AdapterIndex=204,OsIndex=17
29.09.2022 15:10:22 - IpsDial: connection time interface choice,LocIpa=192.168.2.46,AdapterIndex=204,OsIndex=17
29.09.2022 15:10:22 - Ikev2: Outgoing connect request IKEv2 mode - gateway=xx.xxx.xx.xx : M71Gateway-VPN_0001
29.09.2022 15:10:22 - Ikev2: ConRef=2, XMIT_MSG1_INIT, name=M71Gateway-VPN_0001, vpngw=xx.xxx.xx.xx:500
29.09.2022 15:10:26 - Isakmp: re-sending packet to=xx.xxx.xx.xx:500,size=576
29.09.2022 15:10:30 - Isakmp: re-sending packet to=xx.xxx.xx.xx:500,size=576
29.09.2022 15:10:34 - Isakmp: re-sending packet to=xx.xxx.xx.xx:500,size=576
29.09.2022 15:10:38 - ERROR - 4021: IKEv2(INIT) - Could not contact Gateway. Please check your internet connection.
29.09.2022 15:10:38 - Ikev2: phase1:name(M71Gateway-VPN_0001) - ConRef=2,ERROR - retry timeout - max retries
29.09.2022 15:10:38 - IPSec: Disconnected from M71Gateway-VPN_0001 on channel 1.
29.09.2022 15:10:38 - INFO - MONITOR: Communication Medium changed  -  Wi-Fi => Automatic
29.09.2022 15:10:38 - INFO - MONITOR: Disconnected
29.09.2022 15:10:38 - INFO - MONITOR: Media=Wi-Fi, Tx=0 Byte, Rx=0 Byte
Wenn ich mir das ansehe, versucht der Client eine Verbindung zu der public IP des LANCOMs aufzubauen, auf Port 500. Generell erreichbar ist die IP, aber benötigt der LANCOM noch sowas wie eine Portfreigabe?

Gefühlt ist mein Setup hier denkbar einfach, nachdem der LANCOM ohne Umwege direkt am DSL Kabel hängt.
Zuletzt geändert von m71service am 29 Sep 2022, 16:02, insgesamt 1-mal geändert.
Benutzeravatar
hotzenplotz
Beiträge: 42
Registriert: 06 Nov 2020, 14:27
Wohnort: Niederrhein

Re: VPN zwischen LANCOM R883VAW und LANCOM Client

Beitrag von hotzenplotz »

Moin!

Generell ist es m.E. erst einmal sinnvoll im Client das Verbindungsmedium von Auto auf "LAN (over IP)" zu stellen.

Dann müsstest Du einmal am Router einen VPN-Trace durchführen. Dies entweder über die Konsole via SSH oder über die Lanconfig bzw. den Lanmonitor.
Du benötigst fürs erste den VPN-Status Trace.

Die Ausgabe dort dann einmal hier posten.

BTW: Ich würde einmal deine Public IP aus dem Log unkenntlich machen.

Grüße!
m71service
Beiträge: 3
Registriert: 29 Sep 2022, 15:02

Re: VPN zwischen LANCOM R883VAW und LANCOM Client

Beitrag von m71service »

Aye, erst mal danke für den Hinweis, die IP hab ich ausgext :)

Ich glaub das war schon mal ein guter Tipp, hier ist die Ausgabe

Code: Alles auswählen

[VPN-Status] 2022/09/29 16:07:18,783  Devicetime: 2022/09/29 16:07:20,762
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 556 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0xF09CC6CAF73D6E2A0000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 16:07:22,421  Devicetime: 2022/09/29 16:07:24,405
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 556 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0xF09CC6CAF73D6E2A0000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 16:07:26,458  Devicetime: 2022/09/29 16:07:28,443
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 556 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0xF09CC6CAF73D6E2A0000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 16:07:30,499  Devicetime: 2022/09/29 16:07:32,487
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 556 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0xF09CC6CAF73D6E2A0000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty
Ist dieses "VPN-ID is empty" die gesuchte Fehlermeldung?
Benutzeravatar
hotzenplotz
Beiträge: 42
Registriert: 06 Nov 2020, 14:27
Wohnort: Niederrhein

Re: VPN zwischen LANCOM R883VAW und LANCOM Client

Beitrag von hotzenplotz »

m71service hat geschrieben: 29 Sep 2022, 16:11 Ist dieses "VPN-ID is empty" die gesuchte Fehlermeldung?
Ja.
Wenn im Trace ein "-" am Anfang der Zeile steht, beschreibt dies meist den Fehler.

Schau Dir mal folgende KB-Artikel an:
https://support.lancom-systems.com/know ... VPN-Client

https://support.lancom-systems.com/know ... VPN+Client

Insbesondere im zweiten steht alles drin, was einmal manuell geprüft werden müsste, ob die einzelnen Punkte auch so (korrekt) vorhanden sind.

Grüße!
m71service
Beiträge: 3
Registriert: 29 Sep 2022, 15:02

Re: VPN zwischen LANCOM R883VAW und LANCOM Client

Beitrag von m71service »

Vielen Dank!

Ich hab tatsächlich manuell eine neue Verbindung Schritt-für-Schritt nach der Anleitung im zweiten Link eingerichtet, aber der Log-Trace sieht ziemlich gleich aus irgendwie :G)

Code: Alles auswählen

[VPN-Status] 2022/09/29 18:01:00,780  Devicetime: 2022/09/29 18:01:03,093
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 1060 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0x416D708DB22753300000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 18:01:04,611  Devicetime: 2022/09/29 18:01:06,916
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 1060 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0x416D708DB22753300000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 18:01:08,646  Devicetime: 2022/09/29 18:01:10,950
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 1060 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0x416D708DB22753300000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty

[VPN-Status] 2022/09/29 18:01:12,671  Devicetime: 2022/09/29 18:01:14,985
Peer <UNKNOWN>: Received an IKE_SA_INIT-REQUEST of 1060 bytes
Gateways: xx.xxx.xx.xx:500<--79.226.x.x:10952
SPIs: 0x416D708DB22753300000000000000000, Message-ID 0
-[ISAKMP-PEER-DEFAULT].VPN-ID is empty
Antworten

Zurück zu „Fragen zum Thema VPN“